m&mf

1262728293032»

Comments

  • SiddSidd Member Posts: 202 Capable
    From what it looks like, you are eating faeleaf to cure blind, which is taking dust balance, but the system is either not recognizing it, or is somehow using a failsafe to bring it back. 

    You then spam eating dust (which it's also not recognizing the offbal line) until you successfully cure something. 
  • VeyilsVeyils Member Posts: 1,456 Mythical
    Worth saying to be sure. There has been situations where there's bugs on specific class versions. May not be in this case but best to be sure.
  • DaedrothDaedroth Member Posts: 36 Apprentice
    edited October 2017
    It appears M&MF is having some issues with aeon. Specifically, forgetting you have it. Here's a log: https://ada-young.appspot.com/pastebin/apyg3jp7

    Anyone have an idea how to fix this? Geomancer version 46.


  • MakaelaMakaela Member Posts: 420 Adept
    edited October 2017
    I do not think I was seemed?  Do geomancers have aeon?

    Edit: nvm reread, not related to my issue but a new one entirely
    image
  • RolsandRolsand Member Posts: 867 Adept
    Is there a way to turn off mmf curing, but still make it do stuff the ssc doesnt?
    whatever
  • XenthosXenthos Shadow Lord Member Posts: 5,819 Transcendent
    I think you can mmignore affs that SSC handles (might be some other things too), I know that people have been working to come up with good ways to keep access to the still-useful things.
    image
  • EjderhaEjderha Member Posts: 126 Master
    Xenthos said:
    I think you can mmignore affs that SSC handles (might be some other things too), I know that people have been working to come up with good ways to keep access to the still-useful things.
    Yeah, mmignore affs that SSC and toggle off or set to 0 the sip/scroll/sparkle thresholds is most of what I have done. There are a few little things that can be optimized around, but that gets you most of the way there.
  • Vadi2Vadi2 Member Posts: 14 Novice
    You can mmignore siphealth and etc as well
  • TremulaTremula Banished Quasiroyal Member Posts: 2,543 Transcendent
    http://forums.lusternia.com/discussion/3251/making-ssc-and-mmf-play-nice-windows/

    I wrote a post with detailed, step-by-step instructions on how to ignore everything. I even added screenshots!
                          * * * WRACK AND ROLL AND DEATH AND PAIN * * *
                                         * * * LET'S FEEL THE FEAR OF DEATH AGAIN * * *
              * * * WE'LL KILL AND SLAUGHTER, EAT THE SLAIN * * *
      * * * IN RAVAGING WE'LL ENTERTAIN * * *

    Ixion tells you, "// I don't think anyone else had a clue, amazing form."
  • MrakMrak Member Posts: 183 Adept
    Vadi2 said:
    I've been seeing people struggle with getting m&mf setup for tinkering with. Would it be easier if all of the files were all inside Mudlet like in other systems? Given the much better editor, this makes more sense than it did in the past.
    Yes please! I find it way easier to mess with stuff that lives in Mudlet.
  • DaedrothDaedroth Member Posts: 36 Apprentice
    I can't seem to find a way to stop M&MF's pipe management. I've set coltsfootid to 0, but it keeps stuffing the first available pipe full of the stuff. I don't need any of my pipes to have anything but steam in them, to be honest.

    Help please?
  • MrakMrak Member Posts: 183 Adept
    edited December 2017
    Any ideas on how to make MMF not think that I've cured all aurics when I smoke in octave? I'm 90% sure that the problem lives in the function valid.smoke2(), and that it reads the line as having nothing to cure from steam. Can't figure out what's going wrong though.


    https://pastebin.com/Eu4Hz5Nk

    Edit:
    I doubt folks care much, but I figured out a bandaid for this. 

    Add the following function to your mmf file:
    __
    function underoctave()
    smoke_cure=true
    end
    __

    Call it using mm.underoctave() on a trigger for the octave line.

    This will case you to spam smoking steam every time you get steam balance, and mmf won't think that you've magically cured all your steam affs when octave prevents them from being cured.
    Post edited by Mrak on
  • VeyilsVeyils Member Posts: 1,456 Mythical
    MM doesnt cures deafness/blindness properly at all now. Autocuring does but autocuring really messes you up if you get hit with aeon under blackout or hidden aeon.

    Autocuring doesnt recognise secondary messages so spams the hell out of commands when in aeon.

    Ive mushed together a bit of a fix to use autocuring and mm together a bit.
    Do autocuring toggle EnabledInAeon off and then make a trigger on the aeon secondary line to do this.

    You move sluggishly into action.
    to do

    [code]
    send("ac off")
    if (stupidsystemaeonStatusTimer) then killTimer(stupidsystemaeonStatusTimer) end
    stupidsystemaeonStatusTimer =  tempTimer(4, [[expandAlias("ac on")]])
    [/code]

    Let mm cure aeon for you. This'll turn off the autocuring when you get hit with aeon from any source and then turn it back on soon after



    Its a messy fix for sure but it'll do until autocuring gets fixed up. I'd personally recomend not using autocuring for the ice stack as well. MM handles aeon, sap and Ice a much better than autocuring right now. The ice one isnt too bad but if you let the autocuring handle your aeon it'll get you killed.
  • MrakMrak Member Posts: 183 Adept
    edited December 2017
    There's really no good option right now.

    I managed to bandaid mmf to cure blindness properly. You need to change several lines in your mmf files. I suspect deafness will use some similar fixes, when I find myself willing I'll post an update here. I don't understand how the defense engine works well enough to turn truehearing and trueblind from herb defenses to actions. 
    ___
    conf.blindherb = "faeleaf"

    becomes 

    conf.blindherb = "dust"
    ___
          if contains({"faeleaf", "myrtle"}, what:lower()) then return true end

    becomes

          if contains({"faeleaf", "myrtle","dust"}, what:lower()) then return true end
    ___

          eatcure = "faeleaf",
          onstart = function ()
            eat("faeleaf")
          end,

    becomes

          eatcure = "dust",
          onstart = function ()
            eat("dust")
          end,      


    _____

    The first two should only need to be changed once, the last one needs to be changed several times.

    Edit: OBTW you should mmconfig blindherb dust after these tweaks.
  • VeyilsVeyils Member Posts: 1,456 Mythical
    Are you eating dust to cure blindness Mrak?
  • VeyilsVeyils Member Posts: 1,456 Mythical
    The reason I ask is your better off using sixthsense the skill as it works like a free focus. If you can change eat dust to that that'd probally be better for you.
  • MrakMrak Member Posts: 183 Adept
    I might try to do that at some point, but I'm currently pretty tired of sifting through all that code, and I'm more interested in basic functionality than optimality.
  • HiriakoHiriako Member Posts: 340 Gifted
    edited December 2017
    Ignore what I said here. I found the cause of the issue. Hidden folders with old versions of mmf from a while back.
  • HiriakoHiriako Member Posts: 340 Gifted
    Ok, anybody got an idea to make this work: mm.adddefinition("@time","getTime(true, "hh:mm:ss:zzz")")

    It shows as invalid due to the string inside the string, I think. @timestamp, despite being listed in the custom prompt code, does not work.
  • EjderhaEjderha Member Posts: 126 Master
    edited December 2017
    Hiriako said:
    Ok, anybody got an idea to make this work: mm.adddefinition("@time","getTime(true, "hh:mm:ss:zzz")")

    It shows as invalid due to the string inside the string, I think. @timestamp, despite being listed in the custom prompt code, does not work.
    Looking at a similar example in the mmf docs, try changing the colon between ss and zzz to a decimal point aka "...ss.zzz"

    /edit the example also has the format string in single quotes. 'hh:mm:ss.zzz'
  • HiriakoHiriako Member Posts: 340 Gifted
    edited December 2017
    The solution was to do this:

    mm.adddefinition("time",[[getTime(true, "hh:mm:ss:zzz")]])

    The stuff within hh... was all just formatting and preference. Thanks though! And thanks to the person that shared the fix with me!
  • NyxariNyxari Member Posts: 27 Capable
    Hiriako said:
    Ok, anybody got an idea to make this work: mm.adddefinition("@time","getTime(true, "hh:mm:ss:zzz")")

    It shows as invalid due to the string inside the string, I think. @timestamp, despite being listed in the custom prompt code, does not work.
    For my system I use
    timestamp = tostring(getTime(true,"hh:mm:ss:zzz"))
    Maybe try removing the "" around the getTime function.

  • HiriakoHiriako Member Posts: 340 Gifted
    mm.adddefinition requires that both arguments be a string. 
  • EjderhaEjderha Member Posts: 126 Master
    These solutions all do the same thing. The [[]] let it parse the string within a string, which single quotes would also do. In the original, it doesn't know whether the second " is closing the first or opening a new set.
Sign In or Register to comment.