Anyone familiar with the Nexus Client?

I'm having some issues with scripting... 

For example, 
I made an alias: "swing @tar"
(@tar being target, obviously)

So all I have to do is type "swi" and I swing at my target. 
It works fine. I've been using it against npcs with no problems. 

But today, when trying to work on some other aliases with someone in a spar, I noticed it wasn't working. 
I feel like it has something to do with the targeting?
Every time I tried it kept saying "I don't see that here", or whatever. 
So is there different ways of targeting? @tar for mobs, and something else for players?


  • Variable strings in it never distinguished between players and mobs, IIRC. They're just strings of letters. If I had to guess, the error is in the command syntax sent to the game somewhere. 

    Do you really mean Nexus though, or the newer HTML5 client on the website? "Nexus" isn't supported by IRE anymore, so you could just be facing an old, outdated bug. 

    Either way, a jump to mudlet might not hurt. The coding really isn't that much harder than Nexus' or the HTML5 client, but it's much, much more powerful when you want to do more than simple aliases. There's a lot more people knowledgeable about it, so it's more common you'll find somebody able to help with specific questions. There's a free, complete curing system for it, too! :)

    Mayor Steingrim, the Grand Schema says to you, "Well, as I recall you kinda leave a mark whereever you go."

  • No it's definitely Nexus. 
  • edited September 2015
    Ok, so I made a new discovery.

    While practicing again with @aeldra I noticed that when I "target aeldra" it would say that she was now my target, but it wasn't showing me that she was. Running out of ideas, I decided to CLICK her name, and she then finally began to show up as my target, and THEN all my aliases worked fine.

    So apparently @ tar doesn't apply to players?
    Which I guess isn't too terribly annoying.
    Could've been a lot worse. 

  • KaimanahiKaimanahi The One True Queen
    I think we'd need a little bit more information about what you're doing with your aliases; i.e., the actual code you're using. Getting the "I don't see that here."-type of message means that you are sending a command to the MUD but that your target variable has not been assigned properly (e.g., you are actually sending "swing rat" instead of "swing aeldra"). There is effectively no difference between mobs and players in code (except one is a capitalized string). It has to be something like you're not setting your target correctly, or the alias you're using isn't correctly referencing that target variable.

    But I will reiterate Riluna's advice that you should strongly consider switching over to the Mudlet client. It has expanded functionality, and there's a lot of already established code from other players that you can use (including targeting scripts).
  • I put the code I was using in the original post. 
    But I figured out the issue
    For whatever reason, me targeting aeldra was not working. 
    If I typed in "target aeldra"
    It would say "Your target is now: Aeldra (adventurer)
    Just like when I target a mob, it would say "Your target is now: A starsucker (a denizen)"

    The only difference was, when I had a mob targeted, it would say its name next to a little picture of a target on my interface. 
    But when I had targeted Aeldra, it didn't do that. 
    So I knew it was something do with the targeting.

    Every alias and trigger I made worked on mobs.
    But not on Aeldra, because she wasn't really targeted, for whatever reason.
    But when I CLICKED on her name, it FINALLY set her as my target, making every alias and trigger FINALLY work with her.  

    So I can do it now, they work, I just figured out that I can't target a player by typing "target whoever".

  • Also I tried targeting her in EVERY possible way, I typed her name multiple times to make sure I was spelling it correctly, I tried "player", I tried "adventurer", I tried everything. 

    So it's definitely some sort of targeting issue with the client.

  • DaraiusDaraius Shevat The juror's taco spot
    Posting a snippet of a log or screenshot will help us diagnose the problem. But as someone who migrated from Nexus to Mudlet, I'm going to second the motion that you do the same. Free robust curing system, larger support community, and pretty customizable. It's likely going to be easier to learn the intricacies of the client if you make the switch sooner rather than later (when Nexus becomes completely unsupported!).
    I used to make cakes.

    Estarra the Eternal says, "Give Shevat the floor please."
  • Riluna said:
    Do you really mean Nexus though, or the newer HTML5 client on the website? "Nexus" isn't supported by IRE anymore, so you could just be facing an old, outdated bug. 

    The HTML5 client was rebranded as Nexus several months ago, when IRE officially discontinued support for the old Java Nexus client.


    The TARGET command is an in-game thing, and there might be some issue with the target getting passed from the game to the client. I'll look into it tonight.

  • Haha, like I said, I figured out the problem.
    Thanks though =p 

Sign In or Register to comment.